[mod] RecherchePlus?

Démarré par Alderande, 07 Janvier 2013, 22:05:22

« précédent - suivant »

Alderande

Ah? ça serait peut-être sympa d'avoir des retour alors parce que pour ce mod peredodu a le graphique...et pas moi!  :'(
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

macfly

Après tout dépend des versions php utilisé sur les serveurs.

Par exemple sur un serveur php5.2 j'ai les info-bulles, et pas sur l'autre serveur en php5.4 car des fonctions dépréciées sur php5.4 ne passe plus alors que sur 5.2 elles sont encore tolérées..

Mais sur ces deux serveurs, pas de graphiques nulle part :(

Alderande

Bon j'ai découvert des petits soucis...Pas tout testé encore désolé^^

Alors je fais une recherche globale sur des joueurs qui ne sont ni en"MV" ni "bloqués" mais qui ne sont pas forcément "inactifs" et par rapport à un certain classement.
Déjà je m'aperçois que le classement "flotte" figure toujours aussi bien classement joueur qu'alliance, donc va falloir le supprimer ^^
Donc, j'ai tout de même cherché avec le classement "flotte"; j'ai des résultats!!! alors que ce type de classement n'existe plus  ???
Bref, j'ai testé avec d'autres classement et là c'est un peu plus embêtant car je coche la case "espionné" et les résultats sont surprenant!
Je trouve des joueurs non espionnés de plus à la place des coordonnées de ces joueurs il y a 4 petits points formant un carré.
Quand je décoche "espionné" tout va bien. Donc je suppose qu'il y a embrouille lorsque l'on coche cette case qui n'avait pas ce soucis auparavant.

J'ai remarqué aussi lorsque j'ai un résultat comprenant plusieurs pages, que lorsque je veux aller de la page 1 à la page 2, par exemple, en utilisant la flêche avec les n° de pages (sur la droite du tableau), la page suivante est vide alors que si j'utilise les flèches(à gauche du tableau), j'obtiens les résultats de la page suivante...!

Voilà c'est tout pour l'instant, nous sommes dimanche tout de même ^^ donc on verra ça lundi ^^ ;)
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

peredodu

En fichier attaché, une partie des corrections, à savoir :

1) suppression des positions 'vides' lors de la recherche
2) lien correct avec la tables des espionnages.

Alderande

#34
Oh quel rapidité^^
Merci peredodu je test ça et j'éditerai mon post pour dire si c'est ok ^^

PS: toujours pas une petite idée sur le problème des graphiques?

EDIT: Bon j'ai fait plusieurs tests et les problèmes précédemment rencontrés ne sont pas réapparus ^^ au niveau de la recherche. IMPECC^^
Par contre concernant le problème pour passer d'une page à une autre comme indiqué dans mon post précédent c'est toujours d'actualité ^^

Pour le classement flotte...ok c'est en fait le "classement militaire" ^^

Merci pour ces corrections peredodu ^^
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

peredodu

Un correctif concernant le problème du changement de page.
pour les graphiques ... :(  pas d'idée ...

Bon tests

DarkNoon

Pour les graphiques est ce que artishow est toujours utilisé dans recherche plus ?
Héberger votre OGSpy : Hébergement

Alderande

Heu à première vue il me semble que oui avec cette ligne dans le fichier "graphic_barre.php"
require_once "library/artichow/BarPlot.class.php"; mais bon le problème des graphiques me concernant (je ne sais pas si d'autres sont dans mon cas (FREE peut-être?)) sont dans tous les mods excepté les statistiques dans "espace personnel"

S'il faut virer manuellement toute ligne de ce genre je suis prêt à le faire ^^ mais je suppose que c'est plus compliqué que ça  :-X
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

peredodu

Citation de: darknoon le 13 Février 2013, 14:52:53
Pour les graphiques est ce que artishow est toujours utilisé dans recherche plus ?

Oui, le mod utilise bel et bien artishow.

Citation de: Alderande le 13 Février 2013, 15:41:50
S'il faut virer manuellement toute ligne de ce genre je suis prêt à le faire ^^ mais je suppose que c'est plus compliqué que ça  :-X

Alderande: si tu vires cette ligne, c'est alors sûr qu'aucun graphique ne sera disponible...

La librairie est toujours disponible dans la version 3.1.0 de OGSpy standard.
Ne faut-il plus l'utiliser ?
Si oui, pourquoi ? Incompatibilités ?

Cordialement,
Père dodu

Alderande

Bon je crois que mon problème est plus complexe que ça car en parlant du mod "rechercheplus" et des graphiques, c'est là que je me suis aperçu que je n'avais plus un seul graphique qui s'affichait aussi bien sous OGSPY 3.1.0 que 3.1.2 alors que sur un autre serveur dont je ne suis pas admin et qui n'est pas hébergé chez FREE, j'ai bien les graphiques (exemple le mod "expéditions"). Donc là à première vu le problème se situe chez moi, surtout si peredodu, lui, a bien les graphiques du mod.
Mouarfff je suis dans le flou complet là!!!

Par contre je peux toujours demander à l'admin de l'autre serveur de bien vouloir installer le mod pour test vu qu'il est en 3.1.2.
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

peredodu

Je crois avoir la réponse pour le problème de graphes:

http://forum.ogsteam.fr/index.php?topic=684.0

la librairie artishow semble être déclarée obsolète en version 3.1.2

ayant installé initialement la version 3.1.0 et ensuite fait un upgrade, la librairie existe toujours chez moi et donc ... j'ai les graphes qui s'affichent.

Questions:
pourquoi avoir supprimé cette librairie ?
par quoi la remplacer ?


Alderande

Oui j'étais au courant de cette suppression même si je trouve dommage car j'aime bien les artichauts moi  :P
Mais ce qui est étrange tout de même c'est que j'ai un serveur OGSPY encore sous 3.1.0 et donc je devrais voir les graphs non?!? Or ce n'est pas le cas.
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

macfly

#42
Tu pourrais mettre en lien le dossier zipper artishow que tu as dans le dossier library ?

j'ai trouvé une version php5 mais j'ai des erreurs à causes de fonctions dépréciées dans cette version et qui sont utilisées par les mods  :/

D'ailleurs pas facile à trouver cette lib.

EDIT : En fait c'est bon ... j'ai réussi à debugger tout ça ...j'ai les graphs qui fonctionnent !!!

Alderande

Ah bah voilà^^
En lisant ton message, macfly, je suis allé voir dans mon ftp et dans library je n'avais pas le dossier "artishow" ^^ je l'ai remis et j'ai les graph même sur le mod rechercheplus^^
Thx.
***Au 03/07/2013***
Windows Vista service pack 2
FF 21.0
OGSPY 3.1.3 + Autoupdate 2.0.9 (version tip)sous Hostinger (hébergement gratuit)  PHP Version 5.4.14
Toolbar Xtense 2.5.2
Mod Xtense: 2.4.3 (version tip)
Ogspy Android
Ogame 5.5.1  - Uni 64/Leo/Sirius
---
GM V 1.8
AntiGameOrigin V 5.4.6
InfoCompte V 3.11.6

DarkNoon

Citation de: peredodu le 14 Février 2013, 11:28:53
Je crois avoir la réponse pour le problème de graphes:

http://forum.ogsteam.fr/index.php?topic=684.0

la librairie artishow semble être déclarée obsolète en version 3.1.2

ayant installé initialement la version 3.1.0 et ensuite fait un upgrade, la librairie existe toujours chez moi et donc ... j'ai les graphes qui s'affichent.

Questions:
pourquoi avoir supprimé cette librairie ?
par quoi la remplacer ?



Highcharts a remplacé JQuery dans OGSpy. C'est ce qui est utilisé dans l'espace personnel.
Héberger votre OGSpy : Hébergement