calculressources (version varius9)

Démarré par Gilga, 09 Janvier 2012, 15:33:15

« précédent - suivant »

Gilga

Citation de: varius9 le 09 Janvier 2012, 14:41:02

Sinon mon mod calculressources à jour est téléchargeable ici
Ne pas utiliser l'update mais un desinstall/reinstall sera plus sûr.
Comme j'ai 11 planètes avec 11 lunes, il est possible que ça bug sur des comptes n'ayant pas tj de lunes.
Merci de me dire sur un autre post.

petit retour:

install ok
activation xtense2 ok

je n'ai pas de lune  :'(
par contre pas de mise à jour automatique des ressources planetes selectionnees ou non

importation par copié collé ne fonctionne pas non plus (mais bon, ça c'est des machins des anciennes version ogspy je pense)

error mysql lors de la désinstallation du mod

error mysql quand tenta de reinstall

Database MySQL Error
ErrNo:1062:  Duplicate entry '0-overview' for key 'mod_id'
Query:
INSERT INTO ogspy_xtense_callbacks (mod_id, function, type, active) VALUES (mod_id, "get_overview", "overview", 1)
bon, je vais cleaner ma bdd



en regardant log ogspy:
fonction => mod_install
ligne => 336
file => xxx/ogspy/index.php
[3]

       
  • => xxx/ogspy/mod/calculressources/install.php
fonction => require_once
ligne => 191
file =>xxx/ogspy/includes/mod.php
[2]

       
  • => INSERT INTO ogspy_xtense_callbacks (mod_id, function, type, active) VALUES (mod_id, "get_overview", "overview", 1)
fonction => sql_query
ligne => 184
file =>xxx/ogspy/mod/calculressources/install.php
[1]

       
  • => INSERT INTO ogspy_xtense_callbacks (mod_id, function, type, active) VALUES (mod_id, "get_overview", "overview", 1)
fonction => DieSQLError
ligne => 138
file => xxx/ogspy/includes/mysql.php
09/01/2012 15:28:42 : Erreur critique mysql - Req : INSERT INTO ogspy_xtense_callbacks (mod_id, function, type, active) VALUES (mod_id, "get_overview", "overview", 1) - Erreur n°1062 Duplicate entry '0-overview' for key 'mod_id'
09/01/2012 15:28:34 : [admin] gilga désinstalle le mod "CalculRessources"
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Gilga

#1
en fait il y a un problème avec l'activation du mod dans xtense

#Nom/version du ModType de donnéesStatus du modStatus du lien
10 ()Vue généraleDésactivéActivé


en regardant dans la base de donnée, c'est un problème d'id de mod

donc au desinstall, l'appel xtense ne se desinstall pas non plus
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Shad

Parce que faut modifiez aussi de mémoire Xd. Fais moi un zip de tout sa que je regarde ;)

Je te montrerais ou corrigée pour que tu saches

Gilga

#3
le lien de téléchargement du mod de varius9 est dans la citation en tête de topic   
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Shad

#4
Essaye sa calculressources

J'ai juste modifier le problème xtense.

varius9

Merci pour ton aide shad

J'ai fait tellement de modif directement dans la BD via phpmydamin qu'effectivement il est possible (sur ^^) que l'install se passe mal.
Via phpmydamin il faut aller dans la table xtense_callbacks et vérifier que le mod_id correspond bien à l'id dans la table mod

Normalement j'avais tout rectifié dans l'install et même desintall.php
A croire que non.
J'ai moi ça marche super bien (Xtense envoi bien les ressources à quai)

Je viens de finir de mettre à jour le mod expe et la barre Xtense passée en 2.3.15
Je vais mettre les liens dans le sujet expe.

Gilga

#6
je viens de faire test , c'est ok , l'appel xtense est fonctionnel

par contre ce mod est un peu pénible, je m'explique :

       
  • les ressource des planetes sont correctement affichées (données dernières fois envoyées par xtense)
  • il y a 2 systèmes de mise en mémoire les machins en vert et les truc en jaune
  • il y a des remises a zéro pour les mem vert et jaune ; et une raz totale
bon, après différents essais, j'ai constaté qu'il n'y avait pas moyen de revenir aux ressources d'origine (enfin j'ai pas trouvé)
il faut ressortir du mod, puis y revenir pour réafficher l'état initial

mais attention au bouton RAZ totale, c'est total !
il faut repasser sur les pages vue generale d'ogame avec xtense

autre chose: les couleurs sont forts flashy et je ne trouve pas ça idéal (voire inadapté au skin par defaut)

voili voilou,
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Dudule

Bonsoir,

Je confirme aussi qu'après la mise à jour de la barre xtense 2.3.15 l'envoie de ressource automatique s'effectue correctement ! =)

C'est super, merci beaucoup !

Ceci dit dans les objectifs tu as fait des listes par thèmes, c'est pas mal du tout, mais tout les objectifs n'y sont pas.
Es-ce un oublie ou es-ce que c'est car tu ne peut pas ?

Si tu veut, je peut te faire une liste complète de tous les objectifs manquants, si cela peut t'aider :)
hébergeur : Free-h , ogspy 3.1.0, mod xtense 2.4.0 , Script GM xtense 2.4.0.4

Jedinight

Y'a le module Xtense à mettre à jour également.

Concernant la barre d'outils Firefox, au moment ou j'ai fait la release, je ne sais pas si j'avais les développements de tout le monde.

Mods : Gestion des attaques, Convertisseur, Xtense
Applis : Xtense for Firefox, OGSpy Android
Actuellement en dev : OGSpy Android

Gilga

le module Xtense est dispo en  2.3.14

Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Dudule

Citation de: Jedinight le 10 Janvier 2012, 08:26:35
Y'a le module Xtense à mettre à jour également.

Concernant la barre d'outils Firefox, au moment ou j'ai fait la release, je ne sais pas si j'avais les développements de tout le monde.

Ben pour ma part la xtense 2.3.14 m'as suffit. Par contre la barre firefox non, il as fallu que je passe en 2.3.15.
Donc en gros j'ai :
OGSpy 3.0.8
Mod xtense 2.3.14
Barre xtense 2.3.15
calcul ressources 1.2

:)
hébergeur : Free-h , ogspy 3.1.0, mod xtense 2.4.0 , Script GM xtense 2.4.0.4

Gilga

fais toujours la liste des bat qui manque

il ya ceux de la v3, ça c'est clair

y a pas les hangars
y a pas depot
y a pas astrophysique etc...

mais avoir la liste de ce qui manque sera utile
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2

Dudule

Ok, je te fait ça dans l'aprem, et j'éditerai ce post ;)
hébergeur : Free-h , ogspy 3.1.0, mod xtense 2.4.0 , Script GM xtense 2.4.0.4

varius9

idem mod expe, je n'avais pas les notifications donc je n'ai pas vu vos réponses.

La barre 2.3.15 n'a de plus que la 2.3.14 que l'envoi des pertes RC Expes dans mon mod expe.

Pour ajouter des constructions, il suffit normalement mettre à jour la table calculbesoin.
Affiche moi les ajouts avec les valeur de base de la construction.

Oui, les couleurs semblent réagir bizarrement selon les configs.
css à revoir

Oui, pour recharger les ressources, le mieux est de juste recharger la page sans avoir fait de RAZ mem0
Il faut utiliser la mem1 pour faire ses modifs et garder la mem0 tranquille.
Je devrai d'ailleurs revoir cette option.

Gilga

bonnes nouvelles donc...

les gars de mon ally sont contents de (re)découvrir ce mod m^m en version de test
Windows seven pro, Firefox 15.0.1
Dans ogame v5.1.x  univers quantum   VITESSE X2 
sur ogspy 3.1.0, sur wamp server (php 5.3.13, mysql 5.5.24) et sur OVH (php 5.3.16 )
script GM xtense Version: 2.4.8.1 et/ou barre xtense 2.4.8, mod xtense 2.4.2