extense local erreur : Cross-Origin Request Blocked

Démarré par Tunis, 16 Septembre 2016, 00:40:07

« précédent - suivant »

Tunis

Bonjour, j'ai repris ogame recement et j'ai voulu comme a l'epoque installer ogspy en local (en utilisant xampp)pour me faire mes stats perso de progression,expedition etc...

j'ai reussit a installer ogspy meme si par endroit y'a des erreur php sur certaine page ^^

j'ai ensuite mis xtense, la config est bonne, j'ai eu en premier lieu le bug du contenu mixte, et pour evitez de devoir refaire la manip a chaque lancement j'ai passer le server local en https, j'arrive a y acceder en https maintenant et je n'ai plus le message de contenu mixte par contre j'ai desormais :

Citation00:33:09.147 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://localhost/ogspy/mod/xtense/xtense.php. (Reason: CORS header 'Access-Control-Allow-Origin' missing).1 (unknown)

je dois surement mettre un header quelque part mais  si quelq'un pouvais me detailler la manip n'etant pas un pro :/

j'ai trouver sur google :
Citationheader("Access-Control-Allow-Origin: *");
header("Access-Control-Allow-Methods: PUT, GET, POST");
header("Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept");

ceci mais ou le mettre?
j'ai essayé dans l'index.php (a la racine d'ogspy) et dans l'Xtense.php (celui du dossier du mod) et aussi dans l'index.php du mod xtense.

aucun ne semble faire effet, je pense donc que ce n'est pas ca :/

en esperant que quelq'un connaisse la reponse :)

bonne soirée :)

DarkNoon

Regarde au niveau du fichier mod/xtense/xtense.PHP

Mais normalement ça y est déjà...

Quel est ta config cors dans xtense côté navigateur ?
Héberger votre OGSpy : Hébergement

Tunis

salut,

dans le fichier xtense.php y'a :

Citationif (isset($_SERVER['HTTP_ORIGIN'])) {
    header("Access-Control-Allow-Origin: {$_SERVER['HTTP_ORIGIN']}");
    header('Access-Control-Max-Age: 86400');    // cache for 1 day
} else {
    header("Access-Control-Allow-Origin: *");
}

a la ligne 19. (quelque ligne de code avant en php. j'ai essayé en le mettant en premier ca change rien non plus :p)

coté xtense addon j'ai tenté avec la case CORS coché ou non ca ne change rien :/
pareil pour l'adresse j'ai essayé en https ou en http aucun changement. (normalement le serveur redirige http en https automatiquement)

Aerue

Salut Tunis,

Tu peux aussi te faire refuser sur une preflight request OPTIONS suivant ton navigateur. Le mieux serait de configurer directement apache/nginx pour renvoyer les headers, ou du moins les autoriser.

Tunis

aurais tu un liens avec le detail de la manip a faire pour que ce soit apache qui envoi/autorise les header?


Tunis

#6
aie aie aie

j'arrive a rien x)

a priori j'ai reussi a mettre le header au bon endroit firefox m'ajoute bien les ACCES-Control dans la requete mais y'a toujours erreur 500 :'(

voila des screens de l'erreur actuelle :









j'ai trouver sur google d'autre solution pour l'histoire des preflight, il dise de rajouter :
Citation# Always set these headers.
Header always set Access-Control-Allow-Origin "*"
Header always set Access-Control-Allow-Methods "POST, GET, OPTIONS, DELETE, PUT"
Header always set Access-Control-Max-Age "1000"
Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

# Added a rewrite to respond with a 200 SUCCESS on every OPTIONS request.
RewriteEngine On
RewriteCond %{REQUEST_METHOD} POST
RewriteRule ^(.*)$ $1 [R=200,L]

mais meme ca ne change rien ^^

Aerue

Bon déjà ton soucis de CORS est corrigé o/

Par contre il va falloir que tu ouvre error.log de php pour voir ce qu'il ce passe maintenant, si tu peux me remettre un screen de l'onglet network et du log associé :)

Tunis

merci pour ton aide :)

php ne me genere pas de log :s j'ai bien ete voir le php.ini et pourtant il est censer me log toute les erreurs ^^

sinon dans le log d'apache j'ai trouver ca :
error.log :
Citation[Mon Sep 19 16:25:39.075935 2016] [ssl:warn] [pid 7912:tid 256] AH01909: www.localhost.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Sep 19 16:25:39.183941 2016] [core:warn] [pid 7912:tid 256] AH00098: pid file D:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Sep 19 16:25:39.367951 2016] [ssl:warn] [pid 7912:tid 256] AH01909: www.localhost.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Sep 19 16:25:39.411954 2016] [mpm_winnt:notice] [pid 7912:tid 256] AH00455: Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/5.5.38 configured -- resuming normal operations
[Mon Sep 19 16:25:39.411954 2016] [mpm_winnt:notice] [pid 7912:tid 256] AH00456: Apache Lounge VC11 Server built: Jul  7 2016 11:13:22
[Mon Sep 19 16:25:39.412954 2016] [core:notice] [pid 7912:tid 256] AH00094: Command line: 'd:\xampp\apache\bin\httpd.exe -d D:/xampp/apache'
[Mon Sep 19 16:25:39.413954 2016] [mpm_winnt:notice] [pid 7912:tid 256] AH00418: Parent: Created child process 7836
[Mon Sep 19 16:25:40.020989 2016] [ssl:warn] [pid 7836:tid 268] AH01909: www.localhost.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Sep 19 16:25:40.278003 2016] [ssl:warn] [pid 7836:tid 268] AH01909: www.localhost.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Sep 19 16:25:40.314005 2016] [mpm_winnt:notice] [pid 7836:tid 268] AH00354: Child: Starting 150 worker threads.
[Mon Sep 19 16:25:47.496416 2016] [core:alert] [pid 7836:tid 1716] [client ::1:60040] D:/xampp/htdocs/ogspy/mod/xtense/.htaccess: allow not allowed here, referer: https://s143-fr.ogame.gameforge.com/game/index.php?page=overview
ssl_request.log :
Citation[19/Sep/2016:16:18:35 +0200] ::1 TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384 "POST /ogspy/mod/xtense/xtense.php HTTP/1.1" 1070
access.log :
Citation::1 - - [19/Sep/2016:16:18:35 +0200] "POST /ogspy/mod/xtense/xtense.php HTTP/1.1" 500 1070

et le htacces :
Citation<Files *.js>
Allow from all
</Files>
<Files *.png>
Allow from all
</Files>
<Files *.jpg>
Allow from all
</Files>
<Files *.gif>
Allow from all
</Files>
<Files *.css>
Allow from all
</Files>
deny from all

j'ai essayé en changer le deny from all to allow from all ca change rien :/ (j'ai meme essayé en supprimant le fichier htacces ^^)




Aerue

Il y a a priori un soucis de configuration avec ton certificat SSL.

[Mon Sep 19 16:25:40.278003 2016] [ssl:warn] [pid 7836:tid 268] AH01909: www.localhost.com:443:0 server certificate does NOT include an ID which matches the server name

Attention aussi à bien configurer le allow de ton htaccess pour accepter le referer de ogame.

[Mon Sep 19 16:25:47.496416 2016] [core:alert] [pid 7836:tid 1716] [client ::1:60040] D:/xampp/htdocs/ogspy/mod/xtense/.htaccess: allow not allowed here, referer: https://s143-fr.ogame.gameforge.com/game/index.php?page=overview

roms0406

J'ai eu le probleme au tout début quand je mettais mon serveur sous wampp/xampp
Tu as du faire une erreur à la création de ton certificat ssl
Vu que tu es en local quand tu déclares les variables pour le certif ssl , as tu bien mis l'ip locale quand on te demandait l'adresse du serveur ??

Tunis

il me sembler que oui, je referai tout ce week end, en attendant j'utilise la desactivation du mixte content des navigateurs x)