OGspy 3.4 et mods

Démarré par Mascotte, 30 Novembre 2016, 00:43:29

« précédent - suivant »

Mascotte

Alors ce soir sur le chat, j'ai vu quelques petits problème grâce a un upload de BDD.
J'en profite pour ouvrir ce sujet puisqu'il y aura bientot la 3.4, et un sujet pour qu'on puisse remonter les problemes et autres.


Voici pour ma part (peut-etre que je n'ai pas tout vu) tout ce que a dire en termes d'amélioration ou autres pour cette 3.4
(je suis assez chiant et pointilleux, je préfère le dire)

majuscule dans la BDD

ogspy_parsedRC;
ogspy_parsedRCRound;
ogspy_parsedSpy
ogspy_parsedSpyEn

mod eXpedition :

ogspy_eXpedition
ogspy_eXpedition_attacks
ogspy_eXpedition_fleetCacher
ogspy_eXpedition_items
ogspy_eXpedition_merch
ogspy_eXpedition_nul
ogspy_eXpedition_ress


mod qui me sonde:

ogspy_QuiMeSonde
ogspy_QuiMeSonde_config


Création d'un user :

Lorsqu'on crée un utilisateur le message de création n'est pas bon



URL XTENSE : c'est encore pour l'ancienne barre Xtense de firefox qui est désormais obselete
si l'ont met l'addrese du serveur sans le /index.php sa fonctionne parfaitement (et sa simplifie, ce n'est que mon opignon)

Supprimer le url xtense en vert

et pourquoi pas mettre url xtense mettre a la place = lien a ajouter dans le menu xtense surd'ogame
(pour nous sa parait evident mais pour certaines personnes rien que cela c'est compliqué)

Si j'ai d'autres suggestions

DarkNoon

Héberger votre OGSpy : Hébergement

Vice Artemis

bonsoir
juste pour savoir. ;D
est il prévu une version 3.4?
les mod seront a mettre a jour sans doute ou cela fonctionnera t'il?

DarkNoon

Hello,

La 3.4 est à 70% de son développement.

Mais n'ayant plus de développeurs actifs pour l'avancer elle est à l'arrêt en ce moment. Donc si tu connais des personnes pouvant nous aider ce serait top ;-)

On peut la trouver sur https://github.com/ogsteam/ogspy/tree/develop

Et oui il y aura du boulot sur les mods même si les modifications seront légères : elles seront à faire :-)

Héberger votre OGSpy : Hébergement

Vice Artemis

bonjour
merci du retour.
et non je ne connais personne qui maitrise php, du moins en récent.
mes pauvre connaissance étais celle de quand je mettais mes mains dans le cambouis dans mon ancien forum vbulletin.
en plus ça fait un moment ^^donc aucune utilité pour vous.
je regarde vos gith et essaye déjà de comprendre lol
mais si je trouve ou fait un truc pas de soucis ;)

DarkNoon

Oui si tu vois des choses faciles (Commençons tranquille :-) ) à améliorer n'hésites pas à nous en parler. Nous pourrons te montrer comment faire via le Chat de l'OGSteam ou ici même. ;-)

Héberger votre OGSpy : Hébergement

machine

il y aura également des tests à effectuer ...
des remontés de bugs par exemple sur des versions spécifique

Framework php sécurisé et simple à prendre en main avec générateur web http://mkframework.com/

Vice Artemis

pas de soucis faut juste que mon wamp fonctionne parfaitement ^^
car là ogspy 3.3.2 avec php 5.6.35 apache 2.4.33 et mysql 5.7.21 a des erreurs dans certaine partie.
et comme je suppose que cela devrait fonctionné sans erreur faut que je trouve où est l'erreur chez moi ^^